A Disqus alternative https://posativ.org/isso/
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

48 lines
1.4KB

  1. #!/usr/bin/env python
  2. # -*- encoding: utf-8 -*-
  3. import sys
  4. from setuptools import setup, find_packages
  5. requires = ['itsdangerous', 'Jinja2', 'misaka>=2.0,<3.0', 'html5lib',
  6. 'werkzeug>=0.9', 'bleach']
  7. if sys.version_info < (2, 7):
  8. raise SystemExit("Python 2 versions < 2.7 are not supported.")
  9. elif (3, 0) <= sys.version_info < (3, 4):
  10. raise SystemExit("Python 3 versions < 3.4 are not supported.")
  11. setup(
  12. name='isso',
  13. version='0.12.3dev0',
  14. author='Martin Zimmermann',
  15. author_email='info@posativ.org',
  16. packages=find_packages(),
  17. include_package_data=True,
  18. zip_safe=False,
  19. url='https://github.com/posativ/isso/',
  20. license='MIT',
  21. description='lightweight Disqus alternative',
  22. classifiers=[
  23. "Development Status :: 4 - Beta",
  24. "Topic :: Internet",
  25. "Topic :: Internet :: WWW/HTTP :: HTTP Servers",
  26. "Topic :: Internet :: WWW/HTTP :: WSGI :: Application",
  27. "License :: OSI Approved :: MIT License",
  28. "Programming Language :: Python :: 2.7",
  29. "Programming Language :: Python :: 3.4",
  30. "Programming Language :: Python :: 3.5",
  31. "Programming Language :: Python :: 3.6"
  32. ],
  33. install_requires=requires,
  34. extras_require={
  35. ':python_version=="2.7"': ['ipaddr>=2.1', 'configparser']
  36. },
  37. setup_requires=["cffi>=1.3.0"],
  38. entry_points={
  39. 'console_scripts':
  40. ['isso = isso:main'],
  41. }
  42. )